`
SunnyYoona
  • 浏览: 361542 次
社区版块
存档分类
最新评论

UVA之102 - Ecological Bin Packing

 
阅读更多

Ecological Bin Packing

Background

Bin packing, or the placement of objects of certain weights into different bins subject to certain constraints, is an historically interesting problem. Some bin packing problems are NP-complete but are amenable to dynamic programming solutions or to approximately optimal heuristic solutions.

In this problem you will be solving a bin packing problem that deals with recycling glass.

The Problem

Recycling glass requires that the glass be separated by color into one of three categories: brown glass, green glass, and clear glass. In this problem you will be given three recycling bins, each containing a specified number of brown, green and clear bottles. In order to be recycled, the bottles will need to be moved so that each bin contains bottles of only one color.

The problem is to minimize the number of bottles that are moved. You may assume that the only problem is to minimize the number of movements between boxes.

For the purposes of this problem, each bin has infinite capacity and the only constraint is moving the bottles so that each bin contains bottles of a single color. The total number of bottles will never exceed 2^31.

The Input

The input consists of a series of lines with each line containing 9 integers. The first three integers on a line represent the number of brown, green, and clear bottles (respectively) in bin number 1, the second three represent the number of brown, green and clear bottles (respectively) in bin number 2, and the last three integers represent the number of brown, green, and clear bottles (respectively) in bin number 3. For example, the line 10 15 20 30 12 8 15 8 31

indicates that there are 20 clear bottles in bin 1, 12 green bottles in bin 2, and 15 brown bottles in bin 3.

Integers on a line will be separated by one or more spaces. Your program should process all lines in the input file.

The Output

For each line of input there will be one line of output indicating what color bottles go in what bin to minimize the number of bottle movements. You should also print the minimum number of bottle movements.

The output should consist of a string of the three upper case characters 'G', 'B', 'C' (representing the colors green, brown, and clear) representing the color associated with each bin.

The first character of the string represents the color associated with the first bin, the second character of the string represents the color associated with the second bin, and the third character represents the color associated with the third bin.

The integer indicating the minimum number of bottle movements should follow the string.

If more than one order of brown, green, and clear bins yields the minimum number of movements then the alphabetically first string representing a minimal configuration should be printed.

Sample Input

1 2 3 4 5 6 7 8 9
5 10 5 20 10 5 10 20 10

Sample Output

BCG 30
CBG 50

【解析】

使用枚举法,一共有六种情况,从中选出最小的一个,如果最小的有相同的,按字母顺序输出第一个。

【代码】

/*********************************
*   日期:2013-9-25
*   作者:SJF0115
*   题号: 102 - Ecological Bin Packing
*   来源:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=3&page=show_problem&problem=38
*   结果:AC
*   来源:UVA
*   总结:
**********************************/
#include<stdio.h>
char str[6][4] = {"BCG","BGC","CBG","CGB","GBC","GCB"};
int main(){
	int count[6];
	int B1,B2,B3,C1,C2,C3,G1,G2,G3,min,key;
	//freopen("C:\\Users\\XIAOSI\\Desktop\\acm.txt","r",stdin); 
	while(scanf("%d %d %d %d %d %d %d %d %d",&B1,&G1,&C1,&B2,&G2,&C2,&B3,&G3,&C3) != EOF){
		count[0] = G1+C1+B2+G2+B3+C3;
		count[1] = G1+C1+B2+C2+B3+G3;
		count[2] = B1+G1+C2+G2+B3+C3;
		count[3] = B1+G1+B2+C2+C3+G3;
		count[4] = B1+C1+C2+G2+B3+G3;
		count[5] = B1+C1+B2+G2+C3+G3;
		min = count[0];
		key = 0;
		for(int i = 1;i < 6;i++){
			if(min > count[i]){
				min = count[i];
				key = i;
			}
		}
		printf("%s %d\n",str[key],min);
	}
	return 0;
}



分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics