`
SunnyYoona
  • 浏览: 365248 次
社区版块
存档分类
最新评论

UVA之1330 - City Game

 
阅读更多

【题目】

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems � he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units. The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N. The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input

The first line of the input file contains an integer K � determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The symbols used are:
R � reserved unit
F � free unit
In the end of each area description there is a separating line.

Output

For each data set in the input file print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0

【分析】

最容易想到的算法便是:枚举左上角坐标和长、宽,然后判断这个矩形是否全为空地。这样做需要枚举O(m2n2)个矩形,判断需要O(mn)时间,总时间复杂度为O(m3n3),实在是太高了。本题虽然是矩形,但仍然可以用扫描法:从上到下扫描。

我们把每个格子向上延伸的连续空格看成一条悬线,并且用up(i,j)left(i,j)right(i,j)表示格子(i,j)的悬线长度以及该悬线向左、向右运动的“运动极限”,如图1-30所示。列3的悬线长度为3,向左向右各能运动一列,因此左右的运动极限分别为列2和列4


这样,每个格子(i,j)对应着一个以第i行为下边界、高度为up(i,j),左右边界分别为left(i,j)right(i,j)的矩形。不难发现,所有这些矩形中面积最大的就是题目所求(想一想,为什么)。这样,我们只需思考如何快速计算出上述3种信息即可。

当第i行第j列不是空格时,3个数组的值均为0,否则up(i,j)=up(i-1,j)+1。那么,leftright呢?深入思考后,可以发现:

left(i,j)=max{left(i-1,j),lo+1}

其中lo是第i行中,第j列左边的最近障碍格的列编号。如果从左到右计算left(i,j),则很容易维护loright也可以同理计算,但需要从右往左计算,因为要维护第j列右边最近的障碍格的列编号ro。为了节约空间,下面的程序用up[j]left[j]right[j]来保存当前扫描行上的信息。


【代码】

/*********************************
*   日期:2014-5-19
*   作者:SJF0115
*   题号: 1330 - City Game
*   地址:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=4076
*   来源:UVA
*   结果:Accepted
**********************************/
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

#define N 1001

int matrix[N][N];
int Up[N][N],Left[N][N],Right[N][N];

int main(){
    int T,m,n,i,j;
    //freopen("C:\\Users\\wt\\Desktop\\acm.txt","r",stdin);
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&m,&n);
        //输入
        for(i = 0;i < m;i++){
            for(j = 0;j < n;j++){
                char c = getchar();
                while(c!='R' && c!='F'){
                    c=getchar();
                }
                matrix[i][j]= (c == 'F' ? 0:1);
            }//for
        }//for
        int ans = 0;
        for(i = 0;i < m;i++){
            //从左到右扫描,维护Left
            //障碍列号
            int lcol = -1,rcol = n;
            for(j = 0;j < n;j++){
                //障碍
                if(matrix[i][j] == 1){
                    Up[i][j] = Left[i][j] = 0;
                    lcol = j;
                }
                else{
                    if(i == 0){
                       Up[i][j] = 1;
                       Left[i][j] = lcol + 1;
                    }
                    else{
                        Up[i][j] = Up[i-1][j] + 1;
                        Left[i][j] = max(Left[i-1][j],lcol + 1);
                    }//if
                }//if
            }//for
            //从右到左扫描,维护Right并更新答案
            for(j = n-1;j >= 0;j--){
                //障碍
                if(matrix[i][j] == 1){
                    Right[i][j] = n;
                    rcol = j;
                }
                else{
                    if(i == 0){
                       Right[i][j] = rcol - 1;
                    }
                    else{
                        Right[i][j] = min(Right[i-1][j],rcol - 1);
                    }//if
                    //更新最大矩阵面积
                    ans = max(ans,Up[i][j]*(Right[i][j] - Left[i][j] + 1));
                    //cout<<"ans:"<<ans<<" Up:"<<Up[i][j]<<" Right:"<<Right[i][j]<<" Left:"<<Left[i][j]<<endl;
                }//if
            }//for
        }
        cout<<ans*3<<endl;
    }//while
    return 0;
}




分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics