`
SunnyYoona
  • 浏览: 365396 次
社区版块
存档分类
最新评论

UVA之1388 - Graveyard

 
阅读更多

1388 - Graveyard


Programming contests became so popular in the year 2397 that the governor of New Earck -- the largest human-inhabited planet of the galaxy -- opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose the places for newcomers wisely!

Input

The input file contains several test cases, each of them consists of a a line that contains two integer numbers:n-- the number of holographic statues initially located at the ACM, andm-- the number of statues to be added(2$ \le$n$ \le$1000, 1$ \le$m$ \le$1000). The length of the alley along the park perimeter is exactly 10 000 feet.

Output

For each test case, write to the output a line with a single real number -- the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.

\epsfbox{p3708.eps}

Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.

Sample Input

2 1 
2 3 
3 1 
10 10

Sample Output

1666.6667 
1000.0 
1666.6667 
0.0

【解析】




【代码】

/*********************************
*   日期:2013-11-25
*   作者:SJF0115
*   题号: 题目1388 - Graveyard
*   来源:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=446&page=show_problem&problem=4134
*   结果:AC
*   来源:UVA
*   总结:
**********************************/
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;


int main() {
    int i,n,m;
    while(scanf("%d %d",&n,&m) != EOF){
        double ans = 0.0;
        for(i = 1;i < n;i++){
            //计算每个需要移动的雕塑坐标
            double pos = (double)i / n * (n+m);
            //累加移动距离
            ans += fabs(pos - floor(pos+0.5))/(n+m);
        }
        printf("%.4lf\n",ans * 10000);
    }//while
    return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics